Powerdynamo has sold its business to VAPE
Those pages here are to render support for material sold by Powerdynamo

Company

Products

Technical Help

Search

      

How to check whether the advance unit might be faulty.
Note: Those instructions apply to units with external sensor only.
Units made for internal pickup systems may not be check that or any other way (except by us).
First off all, refrain from checking the unit itself by any electronic or electric means! This is a highly sophisticated electronic part and you risk damaging it without getting sensible information from the procedure applied.

Check whether you have one of the older versions of advance unit that needed a separate voltage supply. You recognise those units by the existance of an single green/red wire (systems with numbers xx xx 899 xx). If you have one of those, please read here.

#

Disconnect the advance unit and connect the cable from the stator
(the unit inside your engine) directly to the ignition coil. The 2 plugs will match. Should you have changed connector pieces, make sure that you connect red to red, yellow to yellow and white to white (in some cases brown).

#

SINGLE SPARK PLUG SYSTEMS:
Take the spark plug out and take the spark plug cap off.

TWIN SPARK PLUG SYSTEMS:
Take both plugs out and both caps off.
Connect one high tension cable (no relevance which one) to ground. (Best screw into its end a small wood screw, similar to what you have at the rear of a spark plug cap and clamp that securely to the engine.)


#

Press the free high tension cable (without the spark plug cap) carefully and securely by help of some well insulating material (rubber, uncoated plastic) against the engine casing or the cylinder.

#

Ask a second person to kick the starter lever of the bike. You will not be able to do kicking and spark observing at the same time and it needs real kicking, not just slow pressing of the starter lever to get the system sparking.

#

If you now observe sparks which have not been present with the advance unit installed and if the resistance test as outlined here has shown normal values, you have an indication that the unit might be faulty.

#

Please note that the engine would not start or at least not run properly without the advance and the wiring as outlined above as timing is wrong now.
back to trouble shooting page